Azure degradation in West US 2 region

Incident Report for m506

Resolved

This incident has been resolved.
Posted May 29, 2026 - 11:11 UTC

Monitoring

The servers are back online, and Command Center is now accessible. We are actively monitoring the systems to ensure continued stability.
Posted May 29, 2026 - 06:34 UTC

Investigating

We are currently experiencing an issue due to the ongoing Azure outage in the West US 2 region. As a result, Command Center is currently inaccessible. Our team is actively engaged with Microsoft, and we will share further updates once the issue is resolved.
Posted May 29, 2026 - 06:18 UTC
This incident affected: Office 365 (West US 2), Database (West US 2), and Web Portal (West US 2).